Посмотрите, какая версия пакета установлена ​​в Ubuntu

Система управления пакетами в Ubuntu делает установку и удаление пакетов чрезвычайно простой, но иногда важно выяснить, какую версию определенного пакета вы фактически установили.

Утилиты apt-get — это просто фронт-енд утилиты debian dpkg, которая фактически выполняет настоящую работу. Вы можете использовать эту утилиту, чтобы выяснить, какая версия установлена.

dpkg -s

Вот пример, где я пытался выяснить, какую версию Ruby я установил в своей системе:

geek @ ubuntuServ: ~ $ dpkg -s ruby1.8

Пакет: ruby1.8
Статус: установлен нормально установлен
Приоритет: не обязателен
Раздел: интерпретаторы
Установлен Размер: 272
Сопровождающий: Ubuntu Core Developers
Архитектура: i386
Версия: 1.8.4-5ubuntu1.2
Зависит от: libc6 (> = 2.4-1), libruby1.8 (> = 1.8.4)
Предлагает: ruby1.8 -examples, rdoc1.8, ri1.8
Описание: Интерпретатор объектно-ориентированного языка сценариев Ruby 1.8
Ruby — это интерпретируемый язык сценариев для быстрого и легкого
объектно-ориентированного программирования. Он имеет множество функций для обработки текстовых файлов
и выполнения задач управления системой (как в perl). Он простой,
простой и расширяемый.
.
Этот пакет предоставляет версию Ruby серии 1.8.
.
В Debian Ruby 1.8 предоставляется как отдельные пакеты. Вы можете получить
полный дистрибутив Ruby 1.8, установив следующие пакеты.
.
ruby1.8 ruby1.8-dev ri1.8 rdoc1.8 irb1.8 ruby1.8-elisp
ruby1.8-examples libdbm-ruby1.8 libgdbm-ruby1.8 libtcltk-ruby1.8
libopenssl-ruby1.8 libreadline-ruby1.8
Оригинал-сопровождающий: akira yamada

Вы можете видеть, что у меня установлена ​​версия 1.8.4.

Оцените статью
TutoryBird.Ru
Добавить комментарий